Sostieni il forum con una donazione! Il tuo contributo ci aiuterà a rimanere online!
Immagine

Tecniche di debug avanzate cercasi

Discussioni di carattere generale sugli effetti analogici e non..
Avatar utente
raf71
Diyer Eroe
Diyer Eroe
Messaggi: 876
Iscritto il: 12/08/2010, 17:24
Località: Pozzuoli (NA)

Re: Tecniche di debug avanzate cercasi

Messaggio da raf71 » 12/12/2017, 14:22

Il fatto di provare il circuito a tratti va bene, ma, secondo me, non nel caso di pedali.
Napoletani si nasce.....

Avatar utente
robi
Amministratore
Amministratore
Messaggi: 7293
Iscritto il: 17/12/2006, 13:57
Località: Alba

Re: Tecniche di debug avanzate cercasi

Messaggio da robi » 12/12/2017, 15:01

Ciao,

scusate ma non ho trovato di quali pedali si parli. Questo aiuterebbe a capire quale problema possa avere.
Io terrei il segnale in ingresso, non iniettato a caso nel circuito, e lo seguirei, "diramazioni" comprese.

Per il debug bisogna prima capire come funzionano le varie parti del circuito, non ci sono tecniche avanzate.
Ma se ci dici cosa stai provando a sistemare, possiamo aiutarti.

Avatar utente
SweeneyTodd
Diyer Eroe
Diyer Eroe
Messaggi: 505
Iscritto il: 17/04/2016, 10:36
Località: Salento

Re: Tecniche di debug avanzate cercasi

Messaggio da SweeneyTodd » 12/12/2017, 20:11

Non avevo volutamente indicato i nomi dei circuiti per farne un discorso più generale e per non aprire ogni volta un thread per ogni pedale che non funziona. Comunque posso dirli, tanto non è mica un segreto.
Uno è lo Slow Gear di Sabrotone. Suona assolutamente pulito senza effetto, dovrebbe tagliare l'attacco alzando gradualmente il volume.
L'altro è una scheda bella grande, il Multiplexer Octave di Guiitar FX, la modern version. Ho l'effetto, ma sembra che il boost che hanno messo nell'output per poter un controllo del volume, e boostarlo eventualmente, non faccia il proprio lavoro, raggiungo appena il volume unitario, leggermente basso a certe regolazioni, e poi fa un grande pop quando attivo e disattivo con lo switch. Dovrebbe essere perfetto, invece.

Avatar utente
raf71
Diyer Eroe
Diyer Eroe
Messaggi: 876
Iscritto il: 12/08/2010, 17:24
Località: Pozzuoli (NA)

Re: Tecniche di debug avanzate cercasi

Messaggio da raf71 » 12/12/2017, 22:14

Lo slowgear è un casino settarlo. Ci metto meno tempo a fare l'allineamento dei ricevitori del radar....

Che fet hai usato? vedi che deve essere un 2sk30a altrimenti non funziona, testato sulla mia pelle. Comunque....accendi il pedale ruota il trimmer a metà, metti la sensibilità al massimo e ritocca il trimmer fino a che non senti l'effetto, ritocchi minimi poichè hai solo una piccola zona del trimmer dove si sente l'effetto. A proposito... mi sembra che lessi qualcosa a proposito di un condensatore da aggiungere in parallelo ad uno che sta sul gate del mosfet.
Napoletani si nasce.....

Avatar utente
robi
Amministratore
Amministratore
Messaggi: 7293
Iscritto il: 17/12/2006, 13:57
Località: Alba

Re: Tecniche di debug avanzate cercasi

Messaggio da robi » 13/12/2017, 10:11

raf71 ha scritto:
12/12/2017, 22:14
accendi il pedale ruota il trimmer a metà, metti la sensibilità al massimo e ritocca il trimmer fino a che non senti l'effetto, ritocchi minimi poichè hai solo una piccola zona del trimmer dove si sente l'effetto.
Non conosco nè il pedale nè lo schema, ma visto il problema, io metterei due resistenze ai capi di un trimmer di valore inferiore: resistenza totale identica, angolo di regolazione del trimmer maggiore.

Tipo, invece di un 25k lin, metto 10k + 5kpot + 10k.
La resistenza totale in serie è 25, l'angolo di regolazione di rotazione del trimmer è quintuplicato.
Quindi semplifichi di molto la regolazione.

Avatar utente
SweeneyTodd
Diyer Eroe
Diyer Eroe
Messaggi: 505
Iscritto il: 17/04/2016, 10:36
Località: Salento

Re: Tecniche di debug avanzate cercasi

Messaggio da SweeneyTodd » 13/12/2017, 10:13

Grazie per l'aiuto, Raf.
Ho rispettato a pieno il layout dello Slow Gear, incluso il 2SK30A. Fra l'altro ho provato anche un 2N5457 (rispettando la piedinatura). A me pare che il trimmer non faccia assolutamente nulla, ottengo zero effetto ad ogni regolazione. Guarderò per l'ennesima volta, non credo di essermi bloccato su un dettaglio del genere per settimane, ma non si sa mai, anzi ci spero, così almeno risolvo.
Al momento senza guardare non ricordo il condensatore di cui parli, ma il layout e lo schema sono verificati, con delle modifiche ben conosciute e già usate spesso che servono a migliorarlo.
Dovrò fare alcune prove proprio oggi.

Grazie per la dritta del trimmer Robi!

Vi faccio sapere.

Avatar utente
SweeneyTodd
Diyer Eroe
Diyer Eroe
Messaggi: 505
Iscritto il: 17/04/2016, 10:36
Località: Salento

Re: Tecniche di debug avanzate cercasi

Messaggio da SweeneyTodd » 15/12/2017, 12:06

Ho provato a ritarare il trimmer cercando un micro sweet spot, ma niente, il trimmer non dà nessun effetto a nessuna regolazione nonostante rilevo lasua resistenza sul resto della board.
I voltaggi sembrano essere giusti, una persona me li ha dati. Unico sospetto un calo di voltaggio sul pin 7 dell'IC TL071, dovrebbe essere 9v, pieno. Invece è di circa 7.20v, causa pensavo una resistenza da 1k.

:????:

Avatar utente
raf71
Diyer Eroe
Diyer Eroe
Messaggi: 876
Iscritto il: 12/08/2010, 17:24
Località: Pozzuoli (NA)

Re: Tecniche di debug avanzate cercasi

Messaggio da raf71 » 15/12/2017, 13:58

http://www.generalguitargadgets.com/wp- ... _notes.txt

Ho trovato qualcosa. Vedi se ti è utile.
Napoletani si nasce.....

Avatar utente
SweeneyTodd
Diyer Eroe
Diyer Eroe
Messaggi: 505
Iscritto il: 17/04/2016, 10:36
Località: Salento

Re: Tecniche di debug avanzate cercasi

Messaggio da SweeneyTodd » 15/12/2017, 23:27

Grazie, ma ce l'ho già. ;) Di norma mi documento bene prima di costruire un circuito. Il layout che ho usato ha quell'elenco di mod lì.

Vedo di recuperare un op-amp da un altro circuito, tanto per fare una prova.

Rispondi