Sostieni il forum con una donazione! Il tuo contributo ci aiuterà a rimanere online!
Immagine

CS-2 chi mi aiuta a fare il debug?

Problemi con un effetto? Esponili qui!
Rispondi
focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 19/07/2018, 15:08

Come da titolo.
Non funzia. Non si sente nessun suono e il led non si accende.
Ho usato lo schema di danieelolivaw e per il truebypass lo schema di generalguitargadgets.
Con il tester ho continuità input/output e massa/massa sui jack di entrata ed uscita.
Da dove si inizia a debuggare?
Grazie.

Avatar utente
raf71
Diyer Eroe
Diyer Eroe
Messaggi: 886
Iscritto il: 12/08/2010, 17:24
Località: Pozzuoli (NA)

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da raf71 » 19/07/2018, 17:59

Ciao.
Inizia a postare lo schema che hai seguito, il layout dei componenti e qualche foto della scheda, lato rame e lato componenti.

Saluti
Raffaele
Napoletani si nasce.....

focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 19/07/2018, 21:18

Qui lo schema e il layout originale

Schema e layout sono estrapolati dal personalissimo lavoro di Daneelolivaw (spero di ricordare bene il nick). A lui tutti i meriti. Pronto a togliere le foto se lui lo ritenesse opportuno
Allegati
schema.jpg
originale.jpg
Ultima modifica di focusright il 19/07/2018, 21:38, modificato 1 volta in totale.

focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 19/07/2018, 21:20

Qui il mio layout che ho rifatto con diylc togliendo la resistenza del led e aumentando lo spessore delle piste, delle piazzole e dei relativi fori.
Allegati
true.jpg
mio.jpg

focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 19/07/2018, 21:24

Lato componenti
Allegati
latocomponenti.jpg

focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 19/07/2018, 21:24

Lato rame
Allegati
latorame.jpg

focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 19/07/2018, 21:30

Prima che a qualche purista venga in mente di fucilarmi...lo so...faccio schifo nelle saldature :muro:
Dallo schema del truebypass non ho eseguito deliberatamente i collegamenti dell'alimentazione della batteria. Tutto il resto è stato fatto come descritto.

Domande:
1) Se provo a bypassare il diodo, come prima prova...che ne pensate?
2) Se collego in e out della pcb all'in e out dei jack (facendo logicamente i collegamenti delle masse), cioè voglio togliere di mezzo tutta la parte del true-bypass, potrebbe essere utile come prova?
3) Misurazioni che potrei fare con il tester? Tipo, se mi vado a cercare lo schema dell'IC ba6110 e vedo quanti volt dovrei avere sul piedino dell'alimentazione?

Altri consigli?

Un saluto a Raf71 che anche un paio di settimane fa mi ha sUpportato e sOpportato. :bye1:

Avatar utente
raf71
Diyer Eroe
Diyer Eroe
Messaggi: 886
Iscritto il: 12/08/2010, 17:24
Località: Pozzuoli (NA)

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da raf71 » 20/07/2018, 7:54

Per cominciare, verifica che le alimentazioni siano corrette sui componenti attivi. Fatto questo sarebbe opportuno iniettare un segnale audio e seguirne il percorso sullo stampato con un audio-probe.

Dalle foto dello stampato lato rame, nella parte superiore a sinistra, sembra che uno dei due fili bianchi, quello più verso il bordo della scheda, vada a massa.
Napoletani si nasce.....

focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 20/07/2018, 17:29

raf71 ha scritto:
20/07/2018, 7:54
Per cominciare, verifica che le alimentazioni siano corrette sui componenti attivi. Fatto questo sarebbe opportuno iniettare un segnale audio e seguirne il percorso sullo stampato con un audio-probe.

Dalle foto dello stampato lato rame, nella parte superiore a sinistra, sembra che uno dei due fili bianchi, quello più verso il bordo della scheda, vada a massa.
Ho 1,6 Volt su tutte le parti attive, dal diodo fino in fondo, compresi pin 1 e 9 dell'ic.
Il filo bianco non va a massa, trattasi di illusione ottica.

focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 20/07/2018, 17:33

Dubbio...non è che sto entrando con i 9v sulla resistenza del led (4k7) e poi sul diodo?

Avatar utente
raf71
Diyer Eroe
Diyer Eroe
Messaggi: 886
Iscritto il: 12/08/2010, 17:24
Località: Pozzuoli (NA)

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da raf71 » 20/07/2018, 22:23

1,6V....
dalle foto non mi sembra che la +9 entri dopo la res del led....quale sarebbe poi questa resistenza?

Piccolo consiglio....la prossima volta, sia gli IC che i transistor montali su uno zoccolo. Questo ti facilita di molto la sostituzione in caso di guasti dovuti ad errori.
Napoletani si nasce.....

focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 21/07/2018, 0:18

raf71 ha scritto:
20/07/2018, 22:23
quale sarebbe poi questa resistenza?
sia gli IC che i transistor montali su uno zoccolo.
La resistenza del led. E' montata fuori la board, con un prolungamento saldato sul pad del 9v.
Il ba6110 è zoccolato (probabile che non si vede dalla foto). I transistor no :muro: Hai ragione, prossima volta "zoccoleggio" tutto.

Aggiornamento: Ho tolto tutto il truebypass e ho collegato direttamente in/out della board con i jack di in/out. Poi ho collegato le masse con il percorso board--->jack out--->jack in--->centrale alimentazione.
Adesso ho 0,3V ovunque.

Vabbè...mi sa che mi sono incartato e non sto debuggando secondo criteri logici.

Rifaccio la pcb prendendo il layout originale e non quello fatto da me.

focusright
Neutrino
Neutrino
Messaggi: 13
Iscritto il: 07/07/2018, 19:47

Re: CS-2 chi mi aiuta a fare il debug?

Messaggio da focusright » 21/07/2018, 22:24

:muro: :muro: :muro:

Non soddisfatto degli 1,6 volt (poi passati a 0,3v) che avevo ovunque sulla scheda, ed essendo "leggermente" pignolo, ho cambiato il dc-jack femmina e... :ok_1:

Provato a vedere le alimentazioni, ora ho 9 volt in ingresso e 7 volt sul 6110.

Rispondi